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Course Description

Improve you Excel skills in this intermediate/advanced Excel hands-on workshop. You will explore some time saving
functions including Trim, Concatenate, and Vlookup. Other topics include: relative and absolute cell referencing,
conditional formatting, referencing cells in another worksheet, formatting data using tables, and creating charts.
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Formulas & Functions
• A formula is an equation used to perform calculations.
• A function is a built-in formula.
• Both start with an equal sign (=).
An example of a formula: =A1+A2+A3+A4+A5
An example of a function:

=SUM (A1:A5)

Useful functions after importing data
When you import data from other sources, such as text delimited from the internet, there may be some problems
with the data, such as extra spaces or you want 1 column for name and there is 2 or visa versa. Here are a few
functions that will help you to easily format the data as you like.
Concatenate
This function is used to join separate strings of data into one. For example, Column A contains last names and
Column B contains first names, what you need is one column that contains first and last name.
Open Data to Concatenate.xlsx
To use the Concatenate Function
1. Insert a column after Column B
2. If you want 1 column of data with Last Name followed by a Comma followed by First name
a. In Cell C2 type the following: =CONCATENATE(A2,", ",B2)
3. If you want 1 column of data with First Name followed by a space followed by Last name
a. In Cell C2 type the following: =CONCATENATE(B2," ",A2)
4. Use the Fill Handle to copy the contents of C2 to fix the rest of names
5. Copy C2:C101
6. Move to Cell A2 and Click on Paste Special and select values (this copies the resulting values in Column C not
the formula
7. Delete columns B and C
Trim
Removes all spaces from the specified data except for single space between words. This function comes in handy if
you were to import data from a text file and there are extra spaces in some of the data.
Open File Data to trim.xlsx
To use the Trim Function
1. The names in column 1 have extra spaces (in front of the name, in between the name and after the name)
2. Insert a column between Columns A & B for the fixed names
3. In cell B2 type the Trim function as follows: =Trim(A1)
a. Now Cell B2 contains the name with all the extra spaces removed except for the 1 space between first
and last name.
4. Copy the contents of cell B2 down the column to fix the rest of the names
5. Copy cells B2:B101
6. Move to Cell A2 and Click on Paste Special and select values (to copy the resulting value in cell B2 not the
formula)
7. Delete column B
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Transform names into upper case
Open List of Names.xlsx
If you want names to be all upper case: (JOHN SMITH)
1. If the names start in column A1, then in cell B1 type =upper(a1)
2. Copy the formula down to all cells to be transformed
3. Select the cells in Col. B
4. Then select the original cells (in Col. A)
5. Then Paste Values (so you don’t copy the formula)
6. Delete Col. B
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Transform names into Proper Case
If you want names to proper case: (John Smith)
1. If the names start in column A1, then in cell B1 type =proper(a1)
2. Copy the formula down to all cells to be transformed
3. Select the cells in Col. B
4. Then select the original cells (in Col. A)
5. Then Paste Values (so you don’t copy the formula)
6. Delete Col. B
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Renaming Sheet Tabs
When you create a Workbook, by default it has 1 Sheet Tab. Called Sheet1. This is not a meaningful name. It is
beneficial to rename the Sheet Tab, especially if there are more than one Sheet in a workbook
Open the following two worksheets:
• Sample Canvas Gradebook.xlsx
• Sample SAM Gradebook.xlsx
To Rename the Sheet tab.
• In the SAM Gradebook, double click the Sheet Tab and type in the new name – SAM Gradebook
• In Canvas Grade book, double click the Sheet Tab and type in the new name – Canvas Gradebook

Move a worksheet into another workbook.
It’s best to have related worksheets in the same workbook
• In the Sample SAM Gradebook, right-click on the Sheet tab and select Move or Copy
• In the Move or Copy Dialog box set To Book: to CIS100-Sample Canvas Gradebook.xlsx
• Set Before sheet: to (move to end)
• Don’t check Create a copy unless you need a copy of the worksheet in its own workbook
• Click OK
Now both worksheets are in the same workbook called Sample Canvas Gradebook.xlsx

Formula references cells in a second worksheet
You can easily reference cells in a formula that are in another worksheet in your workbook. The easiest way to do this
is by using the point mode when constructing the formula instead of typing in the information.
Using the Sample Canvas Gradebook, we want to bring over the SAM final Grade (into the Canvas gradebook sheet)
You’ll see there is a blank column in the Canvas gradebook for SAMs final Grade. However, the final grade in SAMs
needs to be multiplied by 4.
• Click on the Canvas gradebook sheet tab
• Click in cell B3 and Type: =
• Click on the SAMs gradebook sheet tab and then click on cell B3
• Type *4 and press Enter
• The resulting formula is: ='SAMs Gradebook'!B3*4
• Now use the Fill Handle to copy the formula down to the rest of the cells below.
Look in the Formula Bar and notice the way to reference a cell in another sheet in the same workbook: 'SAMs
Gradebook'!B3
Relative vs Absolute Cell Reference
There are two types of cell references: relative and absolute. By default, all cell references are relative references.
They behave differently when copied and filled to other cells. Relative references change when a formula is copied to
another cell. For example, if my formula in cell C1 is =A1 + B1, when I copy it to cell C2, the formula changes to
=A2+B2.
Absolute References will not change when copied. To make a reference absolute you use the dollar sign ($).
$A$1 – The column and the row do not change when copied
$A1 - The column does not change when copied but the row will
A$1 – The row does not change but the column will when copied.
While entering the formula you can type in the $ or you can cycle through the options by pressing the F4 function key
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Formulas needed to complete grade book
Calculate the total points student has earned:
• Use Sample Canvas Gradebook.xlsx
• First we need to calculate total points earned
o Sum total points possible in cell Q2
o Copy formula down the column to cell Q34
• Calculate percentage
o In Cell R3 enter the formula =Q3/$Q$2
o Notice the absolute reference in this formula. It’s used because we don’t want the cell reference to
Q2 to change when copied.
o Copy formula down the column to cell Q34
• Format cells R3:R34 as Percent (%)

Calculate the students letter grade based on % earned.
VLookup
Vlookup allows you to look up a value in your spreadsheet. It Searches for a value in the first column of a table array
and returns a value in the same row from another column in the table array.
Syntax =vlookup(lookup_value, table_array, col_index_num,[range_lookup])
• lookup_value: the value you are searching for
• table_array: the data you want to search
• col_index_num: what column contains value you want vlookup to return
• [range_lookup]: if you want an exact match or an approximate match
o FALSE or 0: exact match
o TRUE or 1: for an approximate match (default, so leave blank if you want an approximate match
o For TRUE sort the leftmost column in ascending order for correct results.
Vlookup in action:
• Create the Grade Lookup Table (on the right) in Cells U2:V6
o Because grades aren’t an exact match, we will be using the TRUE
option so the table data must be sorted in ascending order
• In Cell S3 enter the vlookup function as follows:
o =vlookup(R3,$U$2:$V$6,2)
Breaking down the formula:
• lookup_value: is R3 (the first students grade in percentage
• table_array: is U2:V6 which is the location of the grade lookup table. Notice the cell references are absolute
so that when you copy the formula down the location of the grade lookup table won’t change.
• col_index_num: 2 –the 2nd column of the grade lookup table which contains the actual letter grade that will
be returned.
• [range_lookup] - is not used so that means the formula will find an approximate match.
Analyzing the formula:
 Since cell R3 contains 72, VLOOKUP searches down the 1st column of the grade table for that value.
 Since range_lookup was TRUE (remember when you don’t enter this optional argument, it defaults to true) it
looks for an approximate match.
 Since the table is sorted correctly in ascending order, when VLOOKUP saw that there was no 72 it looked for
a table value based on the lookup_value being less than or equal to the table arguments, in this case 70 is the
largest value less than 72.
 Since the column index number is 2, VLOOKUP looked in the 2nd column and returned the value associated
with 70 which is “C”.
 Now copy the formula down column S to calculate the rest of the student’s letter grade.
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Conditional Formatting
Very useful when there are rows and rows of data. It's one way to draw attention to specific data. You can apply a
rule to any cell or range of cells, highlighting data that meets the rule. For example, you could have a grade
worksheet and create a rule that tells Excel to highlight any cells (in the selected area) that have grades lower than
70%. This will easily identify students that are earning a grade of “D” or “F”.
Let’s assign a rule that says to highlights Students Grades that are lower than 70%. The rule will automatically update
the worksheet if numbers are
The steps:
1. Select the cell or range of cells you want to apply conditional formatting to (the Grade % column.)
2. On the ribbon, go to the Home Tab / Styles Group and click on the Conditional Formatting command
3. Select Highlight Cells Rules from the drop-down menu
4. Click on the Less Than option (since in our example, we want to highlight numbers less than 70%)
5. In the Format Cells that are Less Than box type 70%
6. Select Light Red Fill with Dark Red Text in the With box
7. And click OK
Notice how Excel immediately highlights, in red, the locations that fell below the 70%, and remember If you change
the numbers, the rules still apply. If a change a student’s grade, and they are now at 70% or greater, the red highlight
disappears and vice versa if the grade goes below.
Comparing Two Ranges by Using Conditional Formatting
A common task is comparing two lists of items to identify differences between the two lists. If it’s a big list, doing it
manually is time consuming and prone to error. But Excel can do this for you by using Conditional Formatting.
1. Open Comparing 2 lists.xlsx
2. List 1 is in A2:A20, List 2 is in C2:C20. Name these lists:
a. Select A2:A20
b. In the name box type list1
c. Select C2:C20
d. In the name box type list2
3. To find the names in List 1 that are not in List 2
a. Select the cells in List 1
b. On the Home Tab, select Conditional Formatting
c. Select the option to Use a Formula to Determine Which Cells to Format.
d. Enter the formula =COUNTIF(list2,A2)=0
e. Set the formatting
4. To find the names in List 2 that are not in List 1
a. Select the cells in List 2
b. On the Home Tab, select Conditional Formatting
c. Select the option to Use a Formula to Determine Which Cells to Format.
d. Enter the formula =COUNTIF(list1,C2)=0
e. Set the formatting
Both of these conditional-formatting formulas use the COUNTIF function. This function counts the number of times a
particular value appears in a range. If the formula returns 0, it means that the item doesn’t appear in the range.
Therefore, the conditional formatting rule applies and changes the cell’s background color
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Formatting as a Table
Use a table in Excel, you to manage and analyze the data in that table independently of data outside of the table. For
example, you can filter and sort table columns, add a row for totals, and apply table formatting.
Open Data to Concatenate.xlsx
1. Insert a table
a. Select the cell range (A1:F101)
b. On the Ribbon, select the Insert tab > in the Tables group > click Table
c. In the new window under Where is the data for your table? Make sure the range is the same as the one
you selected
d. Check the box to the right of My table has headers
e. Click OK
2. Table design
a. The Design tab is now showing on the Ribbon and it gives you similar choices as you’ve seen before with
styles, options, and properties
3. Filtering
a. You now have the exact same filtering and sorting options as you once did using AutoFilter
b. Try using one
4. Table expansion
a. Move your mouse pointer to the bottom right corner of the table and hit the TAB key
b. Notice how the added cells change their look and feel to match the table

Creating Charts
Charts and graphs are visual representations of the data. Sometimes the hardest part of charting the data is figuring
out what type of chart to use. Some of common reasons you why you may want to create a chart are:
• To compare one set of values with another – you could use
o Bar Charts,
o Column Charts
o Line Charts
• To show parts of a whole – you could use
o Bar Charts,
o Column Charts
o Pie Charts
• To show Trend over Time – you could use
o Column Chart
o Line Chart
o Sparklines
Open Typing Results.xlsx
Letting Excel Recommend you chart type
Chart how the students did throughout the semester
• Select the data to be charted (cells A2:F14)
• On the Insert Tab / Chart Group / Recommend Charts
• Select the Clustered Column
• Double-Click on the Chart Title to edit the name
Create a Column Chart
We will compare how the students did in week 16
• Select the data to be charted (cells A3:A14 and F3:F14)
• On the Insert Tab / Chart Group / Column
• Select the Clustered Column
• Double-Click on the Chart Title to edit the name
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Create a Pie Chart
Consider using a pie chart when:
• You have only one data series.
• None of the values in your data are negative.
• Almost none of the values in your data are zero values.
• You have no more than seven categories, all of which represent parts of the whole pie.
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Compare how office worker’s time is spent in one work day
• Open Typical Work Day.xlsx
• Select the data to be charted (cells A3:B8)
• On the Insert Tab / Chart Group /Pie Chart
• Select 3-D Pie
• Edit the Chart Title and change the formatting
Sparklines
Tiny charts in a cell that shows trends. They are actually located in the background of a cell. So you can enter text in
the cell and the sparkline can be its background.
Create a Sparkline to show the trend of individual student progress.
• Use Typing Results.xlsx
• Click in Cell G3
• On the Insert Tab / Chart Group /Sparklines and select Line
• In the Insert Sparklines Dialog box,
o Select the data range: Cell B3:F3
o Select where to place sparklines: - G3 (should already be there)
o Click OK
• Go to the Sparkline Design Tab to edit the design
o Click Markers to display a dot for each WPM
o Change the Marker colors

Create a Custom Fill List
Use the Fill Handle to copy certain reserved words (Days of the Week, Months of the Year, Quarters) as a series
• Use a custom fill series based on a new list of items
1. Click the File tab, and then click Options.
2. Click Advanced, and then under General, click Edit Custom Lists.
3. In the Custom lists box, click NEW LIST, and then type the entries in the List entries box, starting with the
first entry. Follow each entry with a comma.
Let’s use Fall Semester, Spring Semester, Summer Semester as the new list
4. When the list is complete, click Add, and then click OK twice.
5. On the worksheet, click a cell, and then type the item in the custom fill series that you want to use to
start the list.
6. Drag the fill handle across the cells that you want to fill.
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Handy Tips
Freeze panes
A pane is a portion of the document window bounded by and separated from other portions by vertical or horizontal
bars. These panes can be “frozen” essentially locking the columns and rows. You want to freeze panes so you can see
the column and or row headings
To Freeze the student’s names and the field names
1. Select the cell just below the field names and just to the right of the student name (cell B4)
2. On the Ribbon, select the View tab > in the Window group > click Freeze Panes > Freeze Panes (in drop down
menu)
Use CTRL-PageDown and CTRL-PageUp to Cycle Through Worksheets
To quickly move to the next worksheet in your workbook,
• use CTRL-PageDown (i.e. press the CTRL key and while this is held down, press the PageDown button).
• To quickly move to the previous worksheet in your workbook, use CTRL-PageUp.
Transposing columns into rows (and vice versa)
Use this tip if your data is formatted in columns and you really need it to be in rows (or the other way around).
• Copy the row or column you’d like to transpose,
• Right click on the destination cell and under Paste Special.
• Select the Transpose. Option
One Click to Select All
Click the corner button (just to the left of the “A” label and just above the “1” of the row numbers
This will select the entire spreadsheet
Ribbon dialog box launcher
At the bottom right of numerous different ribbon groups on various different tabs there is a little box in the bottom
right had corner. This is called a dialogue box launcher. Clicking one will open a dialog box that includes all the tools
in that group, plus more. If it looks familiar to you, it is similar to the dialog box you would get in Office 2003.
Compress pictures
Pictures or other graphical elements embedded in your Excel spreadsheet, can increase the document size. If you
need to email the spreadsheet or post it online, you can make the size much smaller by compressing all the pictures
in the sheet.
• Open pictures.xlsx
• The file size of this workbook is 6.9 MB.
• Select one of the pictures and you should see the Format tab under 'Picture Tools'. In the 'Adjust' group,
choose 'Compress Pictures'.
• Under Compression 'Options
o Don’t check Apply only to this picture
o Check Delete cropped parts of the picture
• Under Resolution
o select the level of compression you want to use (I selected option for email)
• Click 'OK.
• Save the file as compressed pictures.xlsx
• Look in Windows Explorer to compare the file size
o Pictures.xlsx is 6.9 MB
o Compressed pictures.xlsx is 499 KB
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